TFTP-Server un update via telnet

Upgrade-Probleme, Bug-Reports, ...

Moderatoren: TommyTC, alf, Petrus, andreastc, DSL-Hexe, nobody

TFTP-Server un update via telnet

Beitragvon markuskoe » Di 11.01.2005 - 17:32

ich versuche ein update zu machen von meinemm 2500we FW 2.3.11
ich habe folgendes versucht wie bei vigor-users beschrieben.

markus@Vigor10:~> telnet
telnet> open 192.168.1.1
Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.


Password: ******

Type ? for command help

> ?
% Valid commands are:
upnp ddns exit ip ipf log
quit srv sys vpn wan adsl

> ATFTP -p -l /home/markus/v2k5g254.all 192.168.1.1
% Command missing, Valid commands are:
upnp ddns exit ip ipf log
quit srv sys vpn wan adsl


was läuft den da falsch ?
voher habe ich noch übers web TFTP-Server gestartet.

Telnet verwende ich unter Suse9.0 Konsole.
markuskoe
Grünschnabel
 
Beiträge: 6
Registriert: Di 11.01.2005 - 09:09

Beitragvon cne51 » Di 11.01.2005 - 17:46

Der V2500 unterstützt in der Firmware 2.3.11 den von dir genannten Telnet Befehl nicht.

Wenn du per Webinterface des Routers schon den TFTP Server gestartet hast, kannst du die Firmware direkt per FTP Programm in den Router laden.

Aber nicht über einen WLAN Client.

Bei den neuen Firmwares gibt es den Befehl sys tftp um den TFTP Server zu starten.
Benutzeravatar
cne51
Hardcore-Poster
 
Beiträge: 1904
Registriert: Fr 12.09.2003 - 16:37
Wohnort: MS / OS

Beitragvon markuskoe » Di 11.01.2005 - 20:09

hörte sich gut via FTP das neue FW aufspielen aber ich bekomme keine verbindung via FTP zum root.
Als als erstes 192.168.1.1aufrufen dann auf Firmware aktualisieren (TFTP Server) dort dann auf OK klicken und schon sollte der TFTP Server laufen dann wieder zur Linux konsole FTP verbindun zu 192.168.1.1 aber dann kommt toten stille im walde nix passier. was mach ich falsch oder wie kann ich das noch anders machen wenn man Linux hat ?
markuskoe
Grünschnabel
 
Beiträge: 6
Registriert: Di 11.01.2005 - 09:09

Beitragvon markuskoe » Di 11.01.2005 - 21:28

also ich komme genau so weit

markus@Vigor10:~> telnet
telnet> open 192.168.1.1
Trying 192.168.1.1...
Connected to 192.168.1.1.
Escape character is '^]'.


Password: ******


> sys tftpd
% TFTP server enabled !!!

> und hier fehlt mir jetzt der Befehl zum übertragen der daten den
ATFTP -p -l /home/markus/v2k5g254.all 192.168.1.1 geht nicht bzw unterstüzt meine FW noch nicht.

Hat einer eine Idee ?
markuskoe
Grünschnabel
 
Beiträge: 6
Registriert: Di 11.01.2005 - 09:09

Beitragvon cne51 » Mi 12.01.2005 - 06:51

Du musst nicht versuchen vom Router her die Firmware zu holen, sondern vom Computer senden, wenn beim Router der TFTP Server gestartet ist.
Benutzeravatar
cne51
Hardcore-Poster
 
Beiträge: 1904
Registriert: Fr 12.09.2003 - 16:37
Wohnort: MS / OS

Beitragvon markuskoe » Mi 12.01.2005 - 08:48

hm mag sein ich bin was blond aber was meinst du damit "sondern vom Computer senden, wenn beim Router der TFTP Server gestartet ist." ich mach doch nix anderes oder ?
ich starte auf dem Computer Telnet und dann eine verbindung mit open 192.168.1.1 zu dem Rooter und wie dann weiter ?
ich habs mit copy Datei >> Rooter-Adresse bzw mit ATFTP versucht aber beides geht nicht wo habe ich den nu meinen denkfehler ? wie lautet den der Befehl wenn ich telnet auf habe eine verbindung zum rooter die datei von der platte zum rooter zu schicken?
markuskoe
Grünschnabel
 
Beiträge: 6
Registriert: Di 11.01.2005 - 09:09

Beitragvon cne51 » Mi 12.01.2005 - 12:39

Telnet baut eine Verbindung zum Router auf um diesen zu steuern.

Du brauchst aber noch ein Programm auf dem Computer das die Firmware auf den Router überträgt. Per Telnet Befehl geht das nicht.

Ist denn der router im Firmwareupgrade Modus? Blinken die LEDs?
Benutzeravatar
cne51
Hardcore-Poster
 
Beiträge: 1904
Registriert: Fr 12.09.2003 - 16:37
Wohnort: MS / OS


Zurück zu Firmware + Firmware-Upgrade

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron