Probleme mit VNC/VPN (please wait initial screen loading)

NAT, Open Ports, Port Redirect, Address Mapping, Port Trigger, Instant Messenger, Netmeeting, Serveranwendungen wie FTP und Gameserver, Peer2Peer, eDonkey, ...

Moderatoren: TommyTC, alf, Petrus, andreastc, DSL-Hexe, nobody

Probleme mit VNC/VPN (please wait initial screen loading)

Beitragvon mebner » Do 01.12.2005 - 18:39

Hallo,

wir haben ein kleines Problem mit TightVNC.

Hier steht ein V2200E, auf der Remote-Seite ein V2200E+.
Das VPN läuft seit Monaten über L2TP/IPsec und eine Administration der Remote-Clients über TightVNC lief jederzeit ohne Probleme.

Seit heute erhalten wir jedoch nach dem Einloggen nur noch ein "please wait initial screen loading" - das war es dann.
Ein Bildschirm ist nut teilweise oder gar nicht zu sehen, nach einer Weile wird die Verbindung getrennt.


Wir haben diese Woche auf einen neuen Internet-Provider umgestellt.

Da es anfangs Probleme gab (welche sich im Nachinein als durch den Paketfilter verursacht herausgestellt haben), änderten wir die MTU des Routers (Draytek Vigor 2200E) von 1442 auf 1456 (vom Provider vorgegeben) und auf dem Test-Client (Windows XP PRO) auf 1500.

Mittlerweile hat sich herausgestellt, das die vom Provider vorgeschlagene MTU-Änderung für die Katz ist, und der Draytek mit einer MTU von 1492 genauso gut läuft.

Kann es damit zusammenhängen?

Ich habe mittlerweile wieder die alte MTU des 2200E probiert - leider ohne Erfolg.


Ehrlich gesagt bin ich ziemlich ratlos ;-)


Würde mich über Lösungsvorschläge freuen.


Dank euch.


Gruß
Matthias
mebner
Ambitionierter User
 
Beiträge: 54
Registriert: So 07.04.2002 - 11:38
Wohnort: Bayern

Beitragvon mebner » Do 01.12.2005 - 18:55

Hallo,

eben gefunden (aber noch nicht getestet):

-----------------------------------------------------------
The VPN tunnel has an MTU of 1500 bytes, as do all interfaces on all
devices. However, because the VNC IP packets originated from the VNC viewer
and hosts were built for 1500 byte MTU, they must have been fragmented by
the Cisco Routers, in order to accommodate the IPSec headers for transport
through the Internet over the VPN tunnel (the access to the internet was
usually over ISDN, which defaults to a 1500 MTU).

The solution was to reduce the MTU of the VNC host. This can be done in the
registry permanently with:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\<adapter>\Tcpip\Paramet
ers\MTU

which should be set to 1400

The NT server can also be forced to discover the MTU of a path by setting:

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tcpip\Parameters\Enable
PMTUBHDetect

which is a REG_DWORD value. Setting it to 1 forces the NT server to
discover the MTU of the path to the target system (in this case the VNC
viewer). If you set the value to 0, it forces the MTU down to 576, and
doesn't attempt to discover the MTU at all.

Diagnosing the problem in the first place was done by sending pings of
various sizes with the DF bit set to true.

Having made this change, I have had no issues with connectivity through
Internet VPN tunnels.
-----------------------------------------------------------


me
mebner
Ambitionierter User
 
Beiträge: 54
Registriert: So 07.04.2002 - 11:38
Wohnort: Bayern


Zurück zu Anwendungen und Server

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron