POP3-Abfrage dauert immer exakt 60 Sekunden :(

NAT, Open Ports, Port Redirect, Address Mapping, Port Trigger, Instant Messenger, Netmeeting, Serveranwendungen wie FTP und Gameserver, Peer2Peer, eDonkey, ...

Moderatoren: TommyTC, alf, Petrus, andreastc, DSL-Hexe, nobody

POP3-Abfrage dauert immer exakt 60 Sekunden :(

Beitragvon Arichy » Mo 11.06.2007 - 14:20

Hallo, das Abfragen meines Postfaches per POP3 dauert immer exakt 60 Sekunden! Das Problem tritt nur bei Verwendung des Vigor 2900G (mit letzter "aktueller" Firmware) auf. Bei Fritz!Box und IPCop flutscht es wie gewohnt, nur beim Vigor hapert es. Hier die Ausgabe von fetchmail -v:
Code: Alles auswählen
$ fetchmail -v
fetchmail: 6.3.6 fragt pop3.xxx.de ab (Protokoll POP3) um Mo 11 Jun 2007 15:04:00 CEST: Abfrage gestartet
  (40 s Pause)
Versuche, mit x.x.x.x/110 zu verbinden...verbunden.
fetchmail: POP3< +OK <xxxx.xxxx@garbas.ispgateway.de>
fetchmail: POP3> CAPA
fetchmail: POP3< -ERR authorization first
fetchmail: authorization first
fetchmail: Sofortige erneute Abfrage von xxx@pop3.xxx.de
  (20 s Pause)
Versuche, mit x.x.x.x/110 zu verbinden...verbunden.
fetchmail: POP3< +OK <xxxx.xxxxxx@garbas.ispgateway.de>
fetchmail: POP3> USER xxxx
fetchmail: POP3< +OK
fetchmail: POP3> PASS *
fetchmail: POP3< +OK
fetchmail: POP3> STAT
fetchmail: POP3< +OK 0 0
fetchmail: Keine Post für xxxxx bei pop3.xxxx.de
fetchmail: POP3> QUIT
fetchmail: POP3< +OK
fetchmail: 6.3.6 fragt ab pop3.xxxx.de (Protokoll POP3) um Mo 11 Jun 2007 15:05:01 CEST: Abfrage beendet

Die 40 und 20 Sekunden Pause sind immer so.
Kann es sein, dass das was mit identd und Port 113 zu tun hat? Dass der Server eine Authentifizierung per ident haben möchte und darauf immer wartet? Hatte identd mal installiert und in inetd.conf aktiviert und Port 113 auf den Rechner weitergeleitet, aber das hat auch nix gebracht.
Bin ratlos...
Arichy
Grünschnabel
 
Beiträge: 4
Registriert: So 10.06.2007 - 14:49

Beitragvon Mossi » Di 19.06.2007 - 08:59

trag als DNS mal die deines Providers und nicht den Vigor ein und versuch es noch mal
Mossi
Ambitionierter User
 
Beiträge: 37
Registriert: Do 16.03.2006 - 20:54

Beitragvon Arichy » Mi 20.06.2007 - 09:19

Danke für den Wink, habe jetzt in /etc/resolv.conf den Nameserver vom Provider eingetragen und nicht die IP des Routers und jetzt geht die Mail-Abfrage ratz fatz.
Ist das ein Bug?
Arichy
Grünschnabel
 
Beiträge: 4
Registriert: So 10.06.2007 - 14:49

Beitragvon Mossi » Mi 20.06.2007 - 09:49

imho: klares jaein.

Auf der ML zu "The Bat!" wurde kürzlich sowas ähnliches diskutiert - Problem, ich kann mich leider nicht mehr so ganz dran erinnern und habe mir nur die mögliche Lösung gemerkt.

Ich habe jetzt aber nicht wirklich eine Idee, woran es liegen könnte.
Mossi
Ambitionierter User
 
Beiträge: 37
Registriert: Do 16.03.2006 - 20:54

Beitragvon nobody » Mi 20.06.2007 - 14:53

Ich denke schon, das das am router "liegt".
Beispiel mein 2950:
draytek router ip: 192.168.49.254
meine beiden internen nameserver: 192.168.49.251 und 192.168.49.1
(der 2950 verwendet meine internen DNS server um anfragen aufzulösen)
man sieht hier natürlich nicht, wie lange das dauert bis vom Router tatsächlich eine antwort kommt, aber es dauert. Möglicherweise sogar so lange, dass eine Anwendung aufgegeben hätte und die Anfrage nochmal stellen würde.
Die Draytek router, die haben wohl keinen wirklichen dns server, sondern sind "nur" ein dns proxy, und auch der hat nicht alle funktionalität.

nslookup
> server 192.168.49.254
Default server: 192.168.49.254
Address: 192.168.49.254#53
> www.spiegel.de
;; reply from unexpected source: 192.168.49.1#53, expected 192.168.49.254#53
;; reply from unexpected source: 192.168.49.251#53, expected 192.168.49.254#53
Server: 192.168.49.254
Address: 192.168.49.254#53

Non-authoritative answer:
Name: www.spiegel.de
Address: 195.71.11.67
> www.spiegel.de
Server: 192.168.49.254
Address: 192.168.49.254#53

Non-authoritative answer:
Name: www.spiegel.de
Address: 195.71.11.67
> pop.kundenserver.de
;; reply from unexpected source: 192.168.49.1#53, expected 192.168.49.254#53
Server: 192.168.49.254
Address: 192.168.49.254#53

Non-authoritative answer:
Name: pop.kundenserver.de
Address: 212.227.15.181
> set querytype=NS
> spiegel.de
;; reply from unexpected source: 192.168.49.1#53, expected 192.168.49.254#53
;; reply from unexpected source: 192.168.49.1#53, expected 192.168.49.254#53
;; reply from unexpected source: 192.168.49.251#53, expected 192.168.49.254#53
;; connection timed out; no servers could be reached
> set querytype=MX
> spiegel.de
;; reply from unexpected source: 192.168.49.251#53, expected 192.168.49.254#53
;; reply from unexpected source: 192.168.49.251#53, expected 192.168.49.254#53
;; reply from unexpected source: 192.168.49.1#53, expected 192.168.49.254#53
;; connection timed out; no servers could be reached

-------------
Ich vermute, dass das linux und auch das mac os antworten, die nicht von dem server, an den die anfrage gestellt wurde einfach verwerfen (reply from unexpected source)
Je nach Router und Firmware beantwortet das Geräte nur Fragen nach "A" records. Probleme sind auch bei hosts, die mehr als eine IP Adresse haben. Das funktioniert oft auch nicht.

------
z.b. so müsste es sein, hier die richtige antwort:
server 192.168.49.1
set querytype=A
> pop.kundenserver.de
Server: 192.168.49.1
Address: 192.168.49.1#53

Non-authoritative answer:
Name: pop.kundenserver.de
Address: 212.227.15.181
Name: pop.kundenserver.de
Address: 212.227.15.133
Name: pop.kundenserver.de
Address: 212.227.15.149
Name: pop.kundenserver.de
Address: 212.227.15.165
nobody
Hardcore-Poster
 
Beiträge: 1332
Registriert: So 19.09.2004 - 16:45

Beitragvon Mossi » Mi 20.06.2007 - 15:49

Könntest evtl. recht haben, dass es am Router liegt.. Mir fällt gerade ein, dass ich vor recht langer Zeit auch mal so Probleme hatte und daraufhin unter Win noch weitere DNS Server eingetragen hatte und seitdem eigentlich alles problemlos lief.
Mossi
Ambitionierter User
 
Beiträge: 37
Registriert: Do 16.03.2006 - 20:54


Zurück zu Anwendungen und Server

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste