VPN-Verbindung Shrewsoft -> Vigor 2930+

Lan2Lan, VPN, SSL-VPN, Remote DialIn, statische Routen, Radius Setup

Moderatoren: TommyTC, alf, Petrus, andreastc, DSL-Hexe, nobody

VPN-Verbindung Shrewsoft -> Vigor 2930+

Beitragvon Ezzz » Do 09.09.2010 - 22:08

Hallo allerseits,

man glaubt es kaum, aber ich bekomme mit dem guten Vigor einfach keine VPN-Verbindung zu stande. Das einzige was interessanterweise funktioniert, ist die Verbindung mittels SSL-VPN im Internet Explorer (die Java-Verbindung gibt immer einen Timeout zurück). Das hilft mir aber leider nicht weiter, da die meisten anzubindenden Computer keine Windows-Büchsen sind ;-)

In Shrewsoft habe ich folgende Einstellungen:

Adress: 192.168.31.1
Netmask: 255.255.255.0
MTU: 1300
NAT-T an auf Port 4500
IKE Fragentation an
WINS + DNS disabled
Authentication mittels FQDN / Mutual PSK
Phase1: aggressive (Rest auf auto)
Phase2: alles auf auto
Policy: Obtain topology automatically

Ich kann mit mit dem Router verbinden und sehe das auch bei den VPN-Connections. Aber leider kann ich weder den Router im entfernten Netz anpingen, noch andere Geräte. Es ist auch keine Verbindung über Port 80 zu Geräten im entfernten Netz möglich.

ipconfig sagt folgendes:
LAN-Adapter:
Adresse: 192.168.31.1
Gateway: 0.0.0.0

WLAN-Adapter:
Adresse: 192.168.2.100
Gateway: 192.168.2.1

Tunneladapter LAN-Verbindung* 7:

Verbindungsspezifisches DNS-Suffix:
IPv6-Adresse. . . . . . . . . . . : 2001:0:5ef5:79fd:107a:a2a:3f57:fd9b
Verbindungslokale IPv6-Adresse . : fe80::107a:a2a:3f57:fd9b%14
Standardgateway . . . . . . . . . : ::

Tunneladapter LAN-Verbindung* 13:

Medienstatus. . . . . . . . . . . : Medium getrennt
Verbindungsspezifisches DNS-Suffix:

Im Vigor habe ich einen VPN-User erstellt, bei dem alle VPN-Arten angehakt sind. Sonst gibt es da ja nicht viele Möglichkeiten.

Der Shresoft-Trace zeigt mir einen Tunnel von mir (192.168.2.100) zu der WAN-IP des Vigors an. Müsste hier anstelle der 192.168.2.100 evtl. schon direkt die IP stehen, die ich vom entfernten Netz bekomme? Also irgendetwas in Richtig 192.168.31.xxx?

Tja, wie Ihr sicherlich bemerkt habt, bin ich mit VPN noch nicht sonderlich vertraut...
Vielen Dank auf jeden Fall für Eure Hilfe! Eigentlich bin ich von dem 2930 begeistert, wahrscheinlich sitzt der Fehler mal wieder vor dem Monitor... ;-)

Viele Grüße
Ezzz
Ezzz
Grünschnabel
 
Beiträge: 2
Registriert: Do 09.09.2010 - 21:46

Beitragvon Ezzz » Fr 10.09.2010 - 08:21

Ach ja, das Syslog vom Vigor sagt folgendes:

Responding to Aggressive Mode from 91.18.63.xx
ISAKMP SA established with 91.18.63.xx
Receive cleint L2L remote network setting is 0.0.0.0/0
IPsec SA established with 91.18.63.xx

Das klingt doch eigentlich ganz gut. Eine IP bekomme ich aber anscheinend nicht zugewiesen. Über SSL-VPN geht das aber, also sollte das DHCP am Router auch funktionieren.

Viele Grüße
Ezzz
Ezzz
Grünschnabel
 
Beiträge: 2
Registriert: Do 09.09.2010 - 21:46


Zurück zu Fernzugriff und Netzwerkkopplung

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste