Vigor 2760 und LAN-LAN Verbindung

Lan2Lan, VPN, SSL-VPN, Remote DialIn, statische Routen, Radius Setup

Moderatoren: TommyTC, alf, Petrus, andreastc, DSL-Hexe, nobody

Vigor 2760 und LAN-LAN Verbindung

Beitragvon Mossi » Mo 07.10.2013 - 11:41

Hallo alle zusammen!

Ich stehe da vor einem kleinen Problem und finde keine Lösung.
Ein betagter Vigor2600 wurde durch einen Vigor2760 ersetzt. Nachdem die Einwahlprobleme bei T-Online beseitigt wurden, gibt es nur noch einen entscheidenden Pferdefuss:
Ich bekomme partout keine LAN-LAN Verbindung zu dem Gerät zustande!
PPTP Einwahl über SmartVPN funktioniert - nur um das vorwerg zu schieben.

Szenario:
Der Vigor 2760 soll mit einem Vigor 2930 verbunden werden.
Der 2760 soll als Dial-In herhalten, der 2930 entsprechend als Dial-Out. Die Verbindung soll auch nur bei Bedarf aufgebaut werden, was aber eigentlich nichts zur Sache tun sollte.
Ein Tunnelaufbau VOM 2760 ZUM 2930 ist NICHT vorgesehen (muss also die andere Richtung sein!). Als Methode soll IPSec eingesetzt werden.
IPSec Verbindungen zwischen den Vigors mit dem alten Betriebssystem waren nie ein Problem. Mit dem alten 2600 hat es auch wunderbar funktioniert! Mit dem 2760 scheitere ich aber kläglich.
Ich habe schon alle möglichen Anleitungen durchwühlt, aber es werden immer nur folgende Szenarien beschrieben:
- alter Vigor mit altem Vigor
- neuer Vigor mir neuem Vigor (z.B. zwei 2760 untereinander)
- Vigor mit Fremdmarke

Aber "Alter Vigor" mit "neuem Vigor" taucht nirgends auf.

Möchte ich einen IPSec Tunnel herstellen, erscheint beim 2760 folgendes im Protokoll:

Code: Alles auswählen
syslog: packet from xxx.xxx.xxx.xxx:500: initial Main Mode message received on xxx.xxx.xxx.xxx:500 but no connection has been authorized with policy=PSK
syslog: packet from xxx.xxx.xxx.xxx:500: received Vendor ID payload [draft-ietf-ipsec-nat-t-ike-00]
syslog: packet from xxx.xxx.xxx.xxx:500: received Vendor ID payload [draft-ietf-ipsec-nat-t-ike-02] meth=107, but already using method 109
syslog: packet from xxx.xxx.xxx.xxx:500: received Vendor ID payload [draft-ietf-ipsec-nat-t-ike-02_n] meth=106, but already using method 109
syslog: packet from xxx.xxx.xxx.xxx:500: received Vendor ID payload [draft-ietf-ipsec-nat-t-ike-03] meth=108, but already using method 109
syslog: packet from xxx.xxx.xxx.xxx:500: received Vendor ID payload [RFC 3947] method set to=109
syslog: packet from xxx.xxx.xxx.xxx:500: received Vendor ID payload [Dead Peer Detection]


Dabei ist es egal, ob ich Main, Agressiv oder verschiedene Kombinationen versuche. Ich habe wohl so ziemlich alle durch, Ergebnis bleibt immer gleich.
Der 2760 hat die aktuelle Firmware 1.1.1 drauf.

Hat wer eine Idee oder Anleitung, wie man was auf beiden Seiten einstellen soll/muss damit es funktioniert?


Zum Testen dann noch L2TP und PPTP im LAN-LAN versucht, aber auch das (also vorläufigen workaround) scheint nicht zu gehen!

Hier mal das Log für L2TP (natürlich ohne IPSec):

Code: Alles auswählen
syslog: control_finish: (StopCCN) Connection closed to xxx.xxx.xxx.xxx, port 1701 (), Local: 1326, Remote: 5
syslog: control_finish: (CDN) Connection closed to xxx.xxx.xxx.xxx, serial 6 ()
pppd[1483]: Connection terminated.
pppd[1483]: Peer XXXXXXX failed CHAP authentication
pppd[1483]: (AUTH PASS) Username XXXXXXX' from 'xxx.xxx.xxx.xxx' matches profile '[L2TP_IN] [MVPNL2L] XXX' (id:1)
syslog: Call established with xxx.xxx.xxx.xxx, Local: 41839, Remote: 8, Serial: 6
syslog: Connection established to xxx.xxx.xxx.xxx, 1701. Local: 1326, Remote: 5 (ref=0/0). LNS session is 'l2tpin.1'
syslog: control_finish: Peer requested tunnel 5 twice, ignoring second one.
syslog: handle_avps: no handler for atribute 5 (Tie Breaker).
syslog: control_finish: Peer requested tunnel 5 twice, ignoring second one.
syslog: handle_avps: no handler for atribute 5 (Tie Breaker).
syslog: handle_avps: no handler for atribute 5 (Tie Breaker).


Und noch für PPTP:

Code: Alles auswählen
pptpd[659]: CTRL: Client xxx.xxx.xxx.xxx control connection finished
pptpd[659]: CTRL: Couldn't write packet to client.
pptpd[659]: CTRL: Couldn't write packet to client.
pptpd[659]: CTRL: Asked to free call when no call open, not handled well
pptpd[659]: CTRL: Client pppd finish wait
pptpd[659]: CTRL: Client pppd TERM sending
pptpd[659]: CTRL: Reaping child PPP[660]
pptp[660]: Connection terminated.
pptp[660]: Peer XXXXXXX failed CHAP authentication
pptp[660]: (AUTH PASS) Username 'XXXXXXX' from 'xxx.xxx.xxx.xxx' matches profile '[PPTP_IN] [MVPNL2L] XXX' (id:1)
pptpd[659]: CTRL: Starting call (launching pppd, opening GRE)
pptpd[659]: CTRL: Client xxx.xxx.xxx.xxx control connection started


Bei L2TP/PPTP scheint es so, als würde der 2930 es nicht im CHAP versuchen, obwohl PAP/CHAP eingestellt ist. Leider kann man CHAP ja nicht fest vorgeben. Der 2760 wiederrum scheint daraufhin direkt "dicht" zu machen, da der 2930 wohl erst versucht mit PAP ranzugehen.

Unterm Strich steht folgendes:
Egal wie ich mich anstelle, ich bekomme beim 2760 keine LAN-LAN Verbindung hin.

Danke für eure Hilfe!
Mossi
Ambitionierter User
 
Beiträge: 37
Registriert: Do 16.03.2006 - 20:54

Re: Vigor 2760 und LAN-LAN Verbindung

Beitragvon brian » Mo 07.10.2013 - 12:31

Hallo Mossi,

in der aktuellen Firmwareversion (1.1.1) ist die Konfiguration von VPN-Tunneln mit dynamischen IP-Adressen nicht möglich.
Dieser Fehler wird mit dem nächsten Update behoben.

MfG
brian
brian
Power-User
 
Beiträge: 194
Registriert: Do 14.10.2010 - 10:15

Re: Vigor 2760 und LAN-LAN Verbindung

Beitragvon Mossi » Mo 07.10.2013 - 12:36

Hallo Brian,

ok, ich brech grad ab :-(
Wenn das wirklich so ist, dann Danke Draytek und hoffentlich gibt es bald einen Fix dafür!

Danke für Deine schnelle Antwort. Schade um die etlichen Stunden Zeit, die mich das gekostet hat.
Mossi
Ambitionierter User
 
Beiträge: 37
Registriert: Do 16.03.2006 - 20:54


Zurück zu Fernzugriff und Netzwerkkopplung

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron