Linux problem wer kann helfen?

Alles rund um die DrayTek Router Familie und Linux

Beitragvon Borg » Fr 13.04.2001 - 20:39

Hallo!!!
habe ein kleines problem. habe linux auf mein rechner installiert aber ich bekomme einfach keine internet verbindung mit dem system hin.

meine ausstattung:
vigor 2000
suse 6.4 und die netzwerkkarte ist eine realtek 8139

welche einstellung muß ich bei linux machen das ich den rechner mit dem internet verbinden kann?

bin um jede antwort dankbar

cu, basti

p.s. mit dem windows kein problem (gleicher rechner)

(Geändert von Borg um 9:40 pm am April 13, 2001)
Borg
Grünschnabel
 
Beiträge: 1
Registriert: Fr 13.04.2001 - 20:34

Beitragvon alf » Sa 14.04.2001 - 00:47

Hallo,

vorrausgesetzt, Deine Netzwerkkarte ist richtig konfiguriert, trage als DNS den Deines Providers ein.

Und schau Dir mal den Verlauf des Themas :

"Vigor2000 Installationsinfos für Linux" an.

Alf.
Benutzeravatar
alf
Ambitionierter User
 
Beiträge: 85
Registriert: Mi 14.03.2001 - 20:46
Wohnort: Berlin

Beitragvon Hans Ederer » Sa 14.04.2001 - 13:00

Hallo,

ich geb mal eine allgemeine Info wie man Netzwerkproblemem unter Linux lösen kann:

1.) Feststellen ob die NIC (Netzwerkkarte) aktiv ist
ifconfig aufrufen und nachsehen ob eth0 da ist
Es sollte eine Zeile kommen die in etwa so aussieht:
eth0 Link encap:Ethernet HWaddr 00:E0:7D:82:6D:98

2.) IP Adresse prüfen
In der 2. Zeile steht die IP Adresse die der Karte zugewiesen worden ist z.B.
inet addr:10.0.0.111 Bcast:10.0.0.255 Mask:255.255.255.0

3.) Kommunikation im lokalen Netz testen
ping <IP Adresse eines Gerätes im lokalen Netz>
hier sollten Reply's kommen.

4.) Ist bisher alles OK dann das Routing überprüfen:
route -n
Solle eine Zeile geben in der z.B.
0.0.0.0 10.0.0.50 0.0.0.0 UG 0 0 0 eth0
steht. 0.0.0.0 ist die default route, 10.0.0.50 der Gateway.

5.) Routing überprüfen
Am besten ein ping an eine Adresse im Internet machen z.B.
ping 217.12.6.16 (www.yahoo.de)

6.) Nameserver überprüfen
Im Verzeichnis /etc gibt's die Datei resolv.conf in der Nameserver des Providers eingetragen sein sollten.

Fehlermöglichkeiten gibt's genug im Netzwerk aber lass mal den Kopf nicht hängen.

Zur besseren Hilfestellung poste bitte den Output von:
ifconfig
route -n
die resolv.conf
und die IP Adresse des Vigors im lokalen Netz (default 192.168.1.1)

CU

Hans
Benutzeravatar
Hans Ederer
Grünschnabel
 
Beiträge: 7
Registriert: Do 12.04.2001 - 11:15
Wohnort: Wien

Beitragvon klaus » Mi 11.07.2001 - 20:38

Hi Basti,

hatte in den letzten Tagen das gleiche Problem. Ich hab's so gelöst, dass ich den Linux-Rechner (SuSE 7.2) als DHCP-Client konfiguriert und im Router (2200 Firmware v1.07)als Primaeren DNS den DNS des ISP (T-Online) eingetragen habe. Funzt jetzt prima.

Viel Erfolg
Klaus B. aus S.
Benutzeravatar
klaus
Grünschnabel
 
Beiträge: 3
Registriert: Mo 16.04.2001 - 12:37
Wohnort: Sandhausen


Zurück zu Sonstiges - DrayTek Router unter Linux

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste

cron