DNS resolver geht nicht richtig - oder client problem ?

Alles rund um die Hardware der DrayTek Vigor 2820 und Vigor 2820V Modelle.

Moderatoren: TommyTC, alf, Petrus, andreastc, DSL-Hexe, nobody

DNS resolver geht nicht richtig - oder client problem ?

Beitragvon nobody » So 06.09.2009 - 10:49

Da habe ich einen 2820. Firmware 3.3.2.1, AnnexB, modem: 2111112
Angeschlossen an einer Telekom Leitung, provider: T-online. DSL 6000

Der User (windows XP SP3) klagt darüber, dass einige bis viele Seiten nicht aufrufbar sind. Egal, ob IE oder Firefox verwendet wird.
Wie sich herausstellt, ist das ein DNS problem. Tritt aber nicht immer auf, jedoch eher häufig, sodass man bei der Arbeit behindert ist.

Ich habe mal testhalber die DNS einstellung (im Router) von automatisch auf opendns gewechselt. Der Fehler bleibt.
Nimmt man aber einen DNS Server (windows basiert), der über VPN erreichbar ist, ist das problem gelöst.
Ist der Client in einem anderen Netz ( dort ist ein 2900 der router, aber ein Windows Server der DNS resolver), dann gibts kein problem.

Aber:
Teste ich auf dem fraglichen PC mit nslookup manuell die Sites, die nicht gehen, so erhalte ich sofort eine korrekte Antwort (vom aktuellen DNS server des providers). Hartnäckig aber gehts weiterhin ( selbst direkt nach der antwort von nslookup ) nicht mit dem Browser. Unter den sites, die nicht funktionieren sind z.B. solche wie google.

Ich habe mit netsh den TCP stack zurückgesetzt, habe das host file kontrolliert, habe mit combofix das system überprüft. Ein aktueller Antivirus-Scanner ist installiert (AVG network edition 8.5, link scanner ist aus, web-shield ist aus).

Resultat: Fehler ist weiterhin vorhanden - keine Besserung.

Das passt irgendwie nicht zusammen.
Bzw.: Ich gehe davon aus, das sowohl eine Windows Anwendungssoftware wie IE die gleichen mechanismen zur Auflösung eines host-namens verwendet, wie nslookup. Wenn diese Annahme richtig ist, dann muss es eigentlich ein Software-problem sein, und, kein problem des Routers

Ist diese Annahme falsch, dann könnte es doch ein Router/Firmware-Problem des Draytek sein - denn mit einem Windows DNS server, da gehts ja ( siehe oben, entweder DNS server über VPN oder direkt)

Ich habe noch weitere 2820 unter meiner kontrolle, allerdings keinen mit dieser Firmware ( meist älter) - dort gibts kein problem.

Firewall (auf router) ist aus. Verbindung ist nicht ausgelastet,
per QoS habe ich für DNS 10% reserviert (in einer eigenen klasse) um sicherzustellen, dass DNS abfragen immer beantwortet werden können.

-------
Bin für jede Idee/Frage/Anregung aufgeschlossen.

Und: gibt es eine Dokumentation der Telnet commandos dieser Firmware? Da ist ja jede menge neues drin.

Danke.
nobody
Hardcore-Poster
 
Beiträge: 1333
Registriert: So 19.09.2004 - 16:45

Zurück zu DrayTek Vigor 2820 / Vigor 2820V Serie

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 0 Gäste